Friday 23rd October 2020

MoodleCloud USA Performance issues in US region

Engineers are investigating reports of increased page load times in the US region.

Update 20201023 16:00 GMT+0: Engineers have identified the cause and a fix is being applied.

Update 20201023 16:10 GMT+0: Engineers confirm the fix is working.