Tuesday 9th February 2021

MoodleCloud USA Performance Issues in US region

Engineers are investigating reports of performance issues in this region.

Update 2021-02-09 15:03 GMT+0: Engineers have confirmed issues with one of the database servers was sporadically under high load for a short period of time last night in this region and are investigating root cause.

Update 2021-02-09 15:38 GMT+0: Engineers have completed the fix and all services are restored.