Monday 2nd August 2021

MoodleCloud USA Performance issues in US region

Engineers are investigating reports of increased page load times in the US region.

Update 20210802 23:55 GMT+8: Engineers have confirmed database connectivity issues for all sites in the MoodleCloud US region and are investigating.

Update 20210802 17:00 GMT+8: Engineers advise root cause of this issue is an atypical increase in demand. All sites are back online.