Tuesday 15th March 2022

MoodleCloud All Regions Performance issues in all regions

Engineers are investigating reports of outages in all regions.

Update 22200315 12:00 GMT+0: Engineers have confirmed partial outages for some sites in all MoodleCloud regions and are investigating.

Update 22200315 04:00 GMT+0: Engineers advise all sites back online in all regions.