Thursday 7th April 2022

MoodleCloud USA Performance issues in US region

The cache server in the US region is under heavy load.

Update 20220407 10:00 GMT+0: The engineering team has identified the issue, a fix is in place and the situation will gradually resource over the next few hours.

Update 20220407 13:00 GMT+0: The engineering team has advised all sites are back online.