Monday 23rd March 2020

MoodleCloud Ireland Performance issues in EU Region

Engineers are investigating reports of increased page load times in the EU region.

Update 20200323 09:00 GMT+0: Engineers have confirmed increased page load times for all sites in the MoodleCloud EU region and are investigating a fix.

Update 20200323 09:15 GMT+0: Engineers advise root cause of this issue is an atypical increase in demand due to COVID-19. Resolution is expected by 16:00 GMT+0.

Update 20200323 14:00 GMT+0: Services are beginning to return to typical performance. Resolution is now expected by 20:00 GMT+0.

Update 20200323 18:00 GMT+0: Services are continuing to improve but are taking longer than expected. Resolution is now expected by 22:00 GMT+0.

Update 20200323 22:00 GMT+0: All services have recovered to normal performance.