Wednesday 25th March 2020

MoodleCloud USA Performance issues in US region

Update 2020-03-25 23:30 GMT+0: Capacity upgrade in this region has been postponed until 2020-03-26 23:00. Temporary capacity measures in place are expected to deliver suitable performance during peak period tomorrow.

Update 2020-03-25 12:00 GMT+0: Emergency changes have restored services to optimal performance in this region. These changes are temporary in nature to buy us some time until we finalise the upgrade in the upcoming change scheduled for 23:00 GMT+0.

Update 2020-03-25 11:45 GMT+0: There is extra heavy load right now that is preventing us from completing the upgrade. Performance should improve by 23:30 GMT+0 and we'll finalise the upgrade overnight. We apologise for the disruption to your day, we're working hard to get everything back to normal for tomorrow.

Update 2020-03-25 11:00 GMT+0: Upgrades today to alleviate performance issues are progressing.

Engineers have identified increased page load times in this region. This issue was anticipated following performance issues at a similar time yesterday as a result of dramatically increased demand due to COVID-19. These symptoms are expected to continue until 2020-03-25 22:00 GMT+0.

We are working on a longer term fix via large scale capacity enhancements now planned for deployment during off-peak time early on 2020-03-26.

Please hang in there with us while the team works hard to bring this upgrade to all users of MoodleCloud in this region, we're doing our best.