Wednesday 2nd September 2020

MoodleCloud USA Performance issues in USA region

Engineers are investigating reports of increased page load times in the USA region.

Update 20200902 14:30 GMT+0: Engineers have confirmed increased page load times for all sites in the MoodleCloud USA region and are investigating.

Update 20200902 23:45 GMT+0: Engineers have identified the cause of performance issues and are working on a fix.